[Activation] VX email sending delays

Incident Report for Piano Software

Resolved

The issue has been identified and resolved.

The incident took place between 08:30 and 11:15 UTC. Our investigation confirmed that email delivery was not affected. The impact was limited to specific internal Mandrill - Piano webhook deliveries, which have now returned to normal functionality.
Posted Jun 23, 2025 - 13:23 UTC

Investigating

We are currently experiencing delays with VX email sending across all environments (US, EU, AP, AU) impacting applications using Mandrill as the email service provider. Our team is actively investigating the issue.
Posted Jun 23, 2025 - 11:31 UTC
This incident affected: Email Distribution (Piano ID and VX transactional Emails).