Piano service disruption due to Cloudflare outage

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:30 UTC

Monitoring

Cloudflare has fixed the issue on their end (https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q), and we are now observing incoming requests on our systems again. We will continue to monitor the situation and provide updates if anything changes.
Posted Dec 05, 2025 - 09:11 UTC

Update

We are currently experiencing a service disruption affecting our services due to an outage on Cloudflare's side.
For reference: https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q
Posted Dec 05, 2025 - 09:10 UTC

Identified

We are currently experiencing a service disruption affecting our services due to an outage on Cloudflare's side. As a result, clients may also experience difficulties logging into Piano dashboards. Our team is actively monitoring the situation.

We apologize for any inconvenience this may cause and appreciate your patience. Further updates will be provided as soon as more information becomes available.

For reference: https://www.cloudflarestatus.com/
Posted Dec 05, 2025 - 08:47 UTC
This incident affected: Dashboards, Interfaces and Platform (Publisher Dashboard - US - https://dashboard.piano.io, Publisher Dashboard - Asia - https://dashboard-ap.piano.io, Publisher Dashboard - Australia - https://dashboard-au.piano.io, Publisher Dashboard - Europe - https://dashboard-eu.piano.io) and API Availability (API Endpoints - US - api.piano.io, API Endpoints - Asia - api-ap.piano.io, API Endpoints - AU - api-au.piano.io, API Endpoints - EU - api-eu.piano.io).