One of our data processing providers experienced an issue with a pipeline, which caused our files to be blocked and delayed.
Actions performed:
We implemented an alternate loading method for new incoming data to restore real-time processing. Our provider has resolved the pipeline issue, and the previously stuck data is now being re-ingested.
Actions to come:
No more actions to come.
Posted Aug 21, 2025 - 15:30 UTC
Resolved
The issue has been resolved and real-time data is now available again. The previously stuck data is currently being re-ingested, and all scheduled exports are being sent.
Posted Aug 21, 2025 - 15:30 UTC
Identified
Real-time data recovery has been restored and is now available. The historical data that remained stuck during the incident is still not accessible at this time. Our teams are actively working on unblocking and recovering this data.
Posted Aug 21, 2025 - 13:49 UTC
Investigating
We are currently experiencing a delay in real-time data processing on Piano Analytics. Scheduled exports will be sent once the data is ready. Our technical teams are actively working to resolve the issue. We apologize for any inconvenience caused.
Affected customers - Less than 1%
Posted Aug 21, 2025 - 12:18 UTC
This incident affected: Data Processing (Piano Analytics Data Processing).