Login captcha feature not working correctly

Incident Report for Piano Software

Resolved

The incident has been resolved.
Posted Mar 19, 2026 - 16:45 UTC

Monitoring

We have successfully implemented a fix for the CAPTCHA issue.

We're actively monitoring the system.
Posted Mar 19, 2026 - 15:40 UTC

Identified

We have identified the issue, and our team is actively working on a fix.

We'll keep you updated on our progress.
Posted Mar 19, 2026 - 15:37 UTC

Investigating

We've received some complaints that end users are unable to pass the CAPTCHA verification. Our development team is currently looking into the issue.
Posted Mar 19, 2026 - 15:14 UTC
This incident affected: Login and Registration (US - id.piano.io, Australia - id-au.piano.io, Asia - id-ap.piano.io, EU - id.piano.io).