Piano Insight is experience a production incident

Incident Report for Piano Software

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 04:45 UTC

Monitoring

Our engineers have identified the root cause and have implemented the fix. We are monitoring the results.
Posted Nov 28, 2025 - 03:54 UTC

Investigating

We noticed a significant traffic drop in Insight started on November 28, 2025 01:54 UTC. Our engineers are investigating the issue.
Posted Nov 28, 2025 - 01:54 UTC
This incident affected: Dashboards, Interfaces and Platform (Piano Insight Dashboard).