Piano Audience/Insight: UI, /traffic API unavailable

Incident Report for Piano Software

Resolved

We observed full restoration of the dashboard and API availability for Insights. This incident has been resolved.
Posted Jun 24, 2025 - 17:18 UTC

Monitoring

A fix has been applied, and we are observing a gradual restoration of functionality to normal levels. We are actively monitoring the results.
Posted Jun 24, 2025 - 08:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 24, 2025 - 05:49 UTC

Identified

Our team is still seeing issues after the initial fix and is continuing to pursue other solutions. We will continue to provide updates via this channel.
Posted Jun 23, 2025 - 14:31 UTC

Monitoring

An initial fix has been deployed that has reduced error rates to zero. Our team is applying additional changes to ensure stability and monitoring the results.
Posted Jun 23, 2025 - 13:51 UTC

Update

Our team is continuing to investigate the issue and expects to provide a new update within the next two hours.
Posted Jun 23, 2025 - 12:46 UTC

Identified

The issue has been identified and a fix is in progress.
Posted Jun 23, 2025 - 09:56 UTC

Investigating

/traffic/* APIs are currently unavailable. Due to this incident, Piano Insight UI is unavailable, and Audience UI is also partially affected.
Posted Jun 23, 2025 - 09:27 UTC
This incident affected: API Availability (API Endpoints - cxense - api.cxense.com) and Dashboards, Interfaces and Platform (Piano Insight Dashboard, Piano DMP Dashboard).