My Account Widget Loading Issue

Incident Report for Piano Software

Resolved

This incident has been resolved
Posted Jun 24, 2025 - 17:14 UTC

Monitoring

Our developers implemented a fix on all Piano dashboard environments. We are monitoring the performance, and any advances will be updated here.
Posted Jun 24, 2025 - 15:40 UTC

Identified

Our devs have identified an issue where my account widget isn't loading. The content loads after a refresh or multiple refreshes in some instances. Our devs are working on a fix and will post an update as soon as it is available.
Posted Jun 24, 2025 - 15:30 UTC
This incident affected: Other.