Europe - Composer - Experiences targeting custom fields are failing

Incident Report for Piano Software

Postmortem

An infrastructure update to the EU environment introduced an incompatibility that prevented Composer from retrieving Custom Fields. The issue was limited to the EU region and did not affect other environments. The update introduced a behavioural change in the network routing layer where a configuration setting that had previously been relied upon was no longer honoured under the new setup. This incompatibility was not detected during pre-production testing, as the test environments did not fully replicate the conditions needed to surface the issue.

The root cause was identified and the configuration gap was addressed promptly. Piano is taking steps to improve parity between pre-production and production environments and to strengthen the validation process ahead of future infrastructure changes to prevent similar issues.

Posted May 15, 2026 - 09:40 UTC

Resolved

This incident has been resolved.
Posted May 13, 2026 - 18:00 UTC

Monitoring

The issue has been identified and fixed; we're currently monitoring the experience executions.
Posted May 13, 2026 - 14:02 UTC

Investigating

We are currently investigating issues affecting the execution of experiences in our European region for segmentation that relies on custom field rules. Impacted users may notice that experiences are not triggering as expected, not reaching the desired outcome.

Our engineering team is actively investigating the issue.
Posted May 13, 2026 - 13:48 UTC
This incident affected: Composer Experience Execution (Composer Experience Execution - Europe).